Home   Forums   Gallery   Vendors   Advertising   Links
Go Back   DieselRam.com > Diesel Ram Technical Topics > Technical Info: 2nd Gen NON-DRIVETRAIN
Technical Info: 2nd Gen NON-DRIVETRAIN Technical discussion of second generation (1994 - 2002) questions, solutions and upgrades. Please -- DO NOT post drivetrain discussions in this forum.
Reply
 
Thread Tools Search this Thread
  #21  
Old 1 Week Ago
MAXTORQ's Avatar
MAXTORQ MAXTORQ is offline
Administrator
 
Join Date: Jan 2004
Location: GOLDEN ,COLORADO
Posts: 19,624
Send a message via Yahoo to MAXTORQ Send a message via Skype™ to MAXTORQ
Default

Quote:
Originally Posted by datec View Post
Thank You for that I will look at it when I get it back, I'm not sure he will get it all out with just changing the thermostat, which he did and said it is holding better then it was.

Would draining the coolant and using an Airlift vacuum tool to fill it work? I recently acquired one of those.

Nope I have one and it sits in the drawer. Follow the instructions above and you will be fine.
__________________


www.maxtorqdiesel.com
Reply With Quote
  #22  
Old 1 Week Ago
datec datec is offline
Member
 
Join Date: Feb 2014
Posts: 45
Default

Quote:
Originally Posted by MAXTORQ View Post
Nope I have one and it sits in the drawer. Follow the instructions above and you will be fine.
Thank You I will do that and when I do I will post my results.

Today he said it is only dropping 10-12* at gauge with new thermostat, temp into heater core 170* at idle return line from rad a little over 100*.
Reply With Quote
  #23  
Old 5 Days Ago
datec datec is offline
Member
 
Join Date: Feb 2014
Posts: 45
Cool

Quote:
Originally Posted by MAXTORQ View Post
Nope I have one and it sits in the drawer. Follow the instructions above and you will be fine.
Well I got the truck back the other day and still no good heat. He placed a piece of cardboard between the rad. and cond. and it hovered around 170 and the heat was just warm and he said he used his Snap-on coolant vac on it and said I will have to keep the cardboard in place to keep the heat. Well yesterday I took it into the garage and did what Max said and I drained 2.5-3gal out and after refilling I capped the plug aand ran it. Not much of a change so I pulled the plug and used my "no spill" funnel I filled it while on the rad. And nothing. I then pulled the plug with the funnel in place and coolent started to fly out of the hole and then all of a sudden all these bubbles started to excape out while letting the coolant spill out the hole. I let it go until the bubbling stopped and then I plugged the hole. I guess I lost about 1/4gal anti freeze doing that, but figured oh well.

I refilled the rad. put the cap on and filled the overflow about 3/4 full started the truck and it got hot and went to the proper temp. Good it's done, pulled out of the garage locked up and drove home.

Got up this morning started it 40min before I was leaving for work to warm up and just warm inside . After work pulled it in and popped the rad cap it was down about 1qt and the overflow was 3/4 empty, SOAB. Well this time I put my "no spill" funnel on and filled it 1/2 way and let the truck run for an hour to get it to temp. I was squeezing the upper rad hose while it was running and more bubbles came out into the "no spill" funnel after an hour it got to temp and more bubbles I was squeezing the rad hose too while all this was going on until no more bubbles and heat coming out of the vents measured 150*. I figured I finally got it.

Closed up shop drive to get fuel still good heat, driving home heat went to warm and the dash gauge read 150*, SOAB. Hear I go again. Tomorrow I will do it again, except I will pull the hoses off the heater core and force water in one hose and I bet that the trapped air is in there that is the highest spot on the system and I see no other way to evacuate air out of it.

Anybody have any other suggestions? The cooling system including block was bone dry when I filled it and discovered this issue.
Reply With Quote
  #24  
Old 4 Days Ago
bigreddog's Avatar
bigreddog bigreddog is offline
Senior Member
 
Join Date: Oct 2004
Location: Lower Washington State, in a house
Posts: 10,320
Default

What year truck is it?
__________________
'91.5 somewhat stock w-250 4x4 5sp Except for the EVIL twin turbos, K&N filter, two small shopping cart dents in right door, Monroe SENAS-TRAC rear shocks. cheap $35 air horns. KDP tabbed. South Bend clutch 13-1.25 Con O. Max stixs, 4" Rip Exhaust,No Muffler, Old Smokey fuel pin. EGR rear disc. Engine breathed on by Max.
My Black Cloud Is Back!...
2012 3500 crew cab Ram 6spd manual, 8' box
I'm just so tired of being tired
Now on facebook
Reply With Quote
  #25  
Old 4 Days Ago
BLRMKR27's Avatar
BLRMKR27 BLRMKR27 is offline
Senior Member
 
Join Date: Nov 2006
Location: Blackwell,MO
Posts: 611
Default

When I had heat issues with my 01And changed out the heater core, the output was still pretty much the same. I could let my truck warm forever in 30*F temps and it would never show on the temp gauge. Covering all but 10" in the center of my radiator helped but not much. Believe it or not, after reading a lot of forums, I replaced the aftermarket thermostat with a $75.00 one from Cummins and voila! Twice as much heat.
Our trucks have serious cooling systems on them. Better than PS or Dmax it seems. I can fill with fuel, go in and get a coffee, and my gauge will read cool unless I leave truck running. Only thing I can figure from it is that the valve plate(?) on the Cummins tstat has a cone shape as if it meters coolant flow or whatever.
Then I discovered my quad doors weren't latching right. Fixing those sealed the doors better and helped. Who knew it could be that quiet in my truck?!
Both cab corners have holes in mine. Taped over with aluminum duct tape for now. HAHa! Shouldn't be a problem. It'll never see 200mph.
Engine : 350,000 miles and purrs like a kitten still.
__________________
'01, 3500, DRW, 4x4, QC, leather, 345,000mi, BHAF ,3.54, Dana80/60, 47RE auto, MWFI VP44 at 112k, FASS Titanium 150, Banks Power Elbow,
4"Monster exhaust, Ranch Hand Legend frt bumper, silencer ring MIA,Cooper AT3s, Timbo's APPS, Spohn Trackbar upgrade, HellBent Steel DSS, 50hp Maxtorq Injectors.
Mopar 52122362AH Steering upgrade
30' Damon Escaper 5'er 12,000#
Reply With Quote
  #26  
Old 3 Days Ago
datec datec is offline
Member
 
Join Date: Feb 2014
Posts: 45
Default

It's a 2000. As far as the heater core the symptoms act as though there is still an air pocket in it, gets hot when you depress the accelerator and goes to just warm when at an idle. I'm guessing I will have to bleed it again, more aggressively this time and will have to come up with a way to catch any antifreeze that spills out.
Reply With Quote
  #27  
Old 3 Days Ago
MAXTORQ's Avatar
MAXTORQ MAXTORQ is offline
Administrator
 
Join Date: Jan 2004
Location: GOLDEN ,COLORADO
Posts: 19,624
Send a message via Yahoo to MAXTORQ Send a message via Skype™ to MAXTORQ
Default

You said you replaced the water pump correct? With who’s pump Cummins or parts chain?
__________________


www.maxtorqdiesel.com
Reply With Quote
  #28  
Old 2 Days Ago
datec datec is offline
Member
 
Join Date: Feb 2014
Posts: 45
Default

No I haven't replaced the water pump just the thermostat. The water pump is what I was considering if this fails to work.

I went out this morning to start it up and let it run, I popped the hood and seen the overflow went down to 1/4 when I filled it to 3/4, so it sucked more into the radiator since I drove it last.

I have no leaks anywhere so the engine is tight.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 05:47 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright 2016 www.dieselram.com. All material found on this site is property of DieselRam.com.Ad Management plugin by RedTyger