Home   Forums   Gallery   Vendors   Advertising   Links
Go Back   DieselRam.com > Diesel Ram Technical Topics > NEW! Technical Info: 4th Gen DRIVETRAIN
NEW! Technical Info: 4th Gen DRIVETRAIN Technical discussion of fourth generation (2007.5 and up) 6.7L engine and drivetrain questions, solutions and upgrades. For trucks with the 5.9L engine use the appropriate 3rd gen forums.
Reply
 
Thread Tools Search this Thread
  #11  
Old 06-05-2021
smokediver's Avatar
smokediver smokediver is offline
Senior Member
 
Join Date: May 2006
Location: Mississippi
Posts: 4,404
Default

Had some guy try to tell me 180 was too cold and I was washing my cylinders down at that temp...
Don't think I want him touching my truck...not even leaning on it!!
Not that anybody is gonna wrench on it but me....unless I take a road trip to Colorado..
__________________
'07, megacab, 2WD, Dually, 6.7, auto,
H&S XRT, ETE tranny, 500k mi and counting !!
'09, quad cab, Laramie, 2WD, Dually, 6.7, auto.
H&S mini maxx, something fell off under the truck 270k mi
My Other Truck is a Fire Engine!!
Reply With Quote
  #12  
Old 06-05-2021
MAXTORQ's Avatar
MAXTORQ MAXTORQ is offline
Administrator
 
Join Date: Jan 2004
Location: GOLDEN ,COLORADO
Posts: 19,713
Send a message via Yahoo to MAXTORQ
Default

This about sums it up.
Attached Images
File Type: jpeg 392E57F4-2F29-41D6-8685-199E6E4021E8.jpeg (43.3 KB, 18 views)
__________________


www.maxtorqdiesel.com
Reply With Quote
  #13  
Old 4 Weeks Ago
smokediver's Avatar
smokediver smokediver is offline
Senior Member
 
Join Date: May 2006
Location: Mississippi
Posts: 4,404
Default

More fan issues...
Is there a fan solenoid?
Past couple weeks, 3 times now, truck hit 230+ pulling a load.
First time I know for sure fan was NOT engaging fully. It was turning at its usual 25-30% but usually when loaded I hear it kick in harder every few minutes. Saturday it hit 240!! and still wouldn't engage fully. Fan was still turning it's normal low speed.
Turned A/C on and no change in fan speed.
Later checked for codes and had one, I think p0483..? I know I googled it and it said fan speed error..like the actual speed did not match the requested speed.
Fan clutch was changed last year, course I know new ones can go bad too..

I poked around and cannot find any relays but found a few references to a cooling fan relay.

Also, where would I splice in a switch to manually turn the fan on high?
As I understand the computer grounds the relay...wherever it is...to engage full speed. But I'd prefer to send power straight to the fan, not the relay if possible.
__________________
'07, megacab, 2WD, Dually, 6.7, auto,
H&S XRT, ETE tranny, 500k mi and counting !!
'09, quad cab, Laramie, 2WD, Dually, 6.7, auto.
H&S mini maxx, something fell off under the truck 270k mi
My Other Truck is a Fire Engine!!
Reply With Quote
  #14  
Old 4 Weeks Ago
smokediver's Avatar
smokediver smokediver is offline
Senior Member
 
Join Date: May 2006
Location: Mississippi
Posts: 4,404
Default

Learning as I go...
Found out the relay is an integral part of the tipm...

Next question..
Which wires/terminals relate to the engine cooling fan?
I'm thinking install an outside relay, use the computer ground, and add a manual overide switch. Just need a good wiring diagram..
__________________
'07, megacab, 2WD, Dually, 6.7, auto,
H&S XRT, ETE tranny, 500k mi and counting !!
'09, quad cab, Laramie, 2WD, Dually, 6.7, auto.
H&S mini maxx, something fell off under the truck 270k mi
My Other Truck is a Fire Engine!!

Last edited by smokediver; 4 Weeks Ago at 09:48 AM..
Reply With Quote
  #15  
Old 3 Weeks Ago
smokediver's Avatar
smokediver smokediver is offline
Senior Member
 
Join Date: May 2006
Location: Mississippi
Posts: 4,404
Default

Hasn't overheated anymore, but checked codes yesterday and found 0480...fan circuit 1 malfunction...
I've turned the A/C on in the mornings to see if the fan engages and has every time I checked.

Read about a conversion to a Ford 7.3 mechanical fan clutch...the old style with the bi-metal spring. Folks that done it say it's the problem solver.
Adapter is $200..then you need the clutch.
__________________
'07, megacab, 2WD, Dually, 6.7, auto,
H&S XRT, ETE tranny, 500k mi and counting !!
'09, quad cab, Laramie, 2WD, Dually, 6.7, auto.
H&S mini maxx, something fell off under the truck 270k mi
My Other Truck is a Fire Engine!!

Last edited by smokediver; 3 Weeks Ago at 07:17 AM..
Reply With Quote
  #16  
Old 2 Weeks Ago
smokediver's Avatar
smokediver smokediver is offline
Senior Member
 
Join Date: May 2006
Location: Mississippi
Posts: 4,404
Default

The latest...
Too warm again yesterday.
Pulling a 16x44 and 75 miles into the run, its 230+.
Fan had been cycling, I heard it, and just stopped.
Pulled over and the fan is turning, maybe 25%... low speed,
Tapped on the TIPM...nothing
Wiggled wires and plugs..still nothing.

Then I noticed one of the wires in the fan plug pushed out the back of the plug a little.
Disconnected it and sure enough, one pin is about half as far in there as the others, red wire.
Got it pushed back in and fired er back up, fan is roaring.
Whether that was the problem or coincidence, we'll see, but stayed cool the rest of the trip.
:fingers crossed:
__________________
'07, megacab, 2WD, Dually, 6.7, auto,
H&S XRT, ETE tranny, 500k mi and counting !!
'09, quad cab, Laramie, 2WD, Dually, 6.7, auto.
H&S mini maxx, something fell off under the truck 270k mi
My Other Truck is a Fire Engine!!
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 06:10 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
Copyright 2016 www.dieselram.com. All material found on this site is property of DieselRam.com.Ad Management plugin by RedTyger